Installing - ffxivmc.plugin



  • Hello,

    I play on Lamia as well and wanted to use the market plugin you have to help keep the prices updated, but I don't know its installed correctly or how to even tell.

    Can you help me Icehunter, please?



  • Market plugin??? I never made one o.O

    Where is it?



  • You are listed as a contributor here https://github.com/monofuel/ffxivapp-ffxivmc-plugin
    it is used on this website apparently https://japura.net/ffxivmc



  • Ah I see!

    That's because he/she forked my sample plugin, renamed the items and made one of their own but I personally did not know about this one.

    I would suggest making some bug reports on that github repo.

    Thanks :)



  • Oh wow, someone found my project! lamia rocks. I stopped working on it when my job got busy, but I've been working on a newer (much nicer) backend recently. Unfortunately it seems the ffxivapp plugin doesn't work anymore, I"m not sure if maybe i broke something or if ffxivapp can't read the network properly, i'll need to investigate.



  • @monofuel said in Installing - ffxivmc.plugin:

    Oh wow, someone found my project! lamia rocks. I stopped working on it when my job got busy, but I've been working on a newer (much nicer) backend recently. Unfortunately it seems the ffxivapp plugin doesn't work anymore, I"m not sure if maybe i broke something or if ffxivapp can't read the network properly, i'll need to investigate.

    I actually haven't had the time to update the memory module and haven't been able to play in about 10-12 months. I'm going to try to get back in once work dies down and get everything updated ><; It's been too long.



  • I did a little bit of debugging, It might just be funnyness on my machine, I updated to windows 10 since i last worked on my plugin. It seems WinPcapWrapper.GetAllDevices() is not returning all of my devices, So it can't start capturing. It's only returning one device out of the 4 interfaces i have, and I don't recognize the one it is returning. I also tried running without pcap, however it seems that GetXIVServerIPList() always returns an empty list for me. I'll need to see if i can't reproduce the issue on another computer, and maybe dive into debugging those 2 functions.

    bah, work! always getting in the way of fun projects. Hopefully i can work a bit on my new ffxivmc website (this time as a go appengine app rather than nodejs on my vps) and have something useable this weekend, i just need to wire up a few more api endpoints and clean up some code.



  • Making progress on rebuilding my site. got a new page setup to show the price of all crafting shards, to make sure my api is working: https://ffxivmc-1361.appspot.com/?pane=shard

    I can't seem to get my plugin working with ffxivapp since the last maintenance, probably will need to fiddle with things.


Log in to reply
 

Looks like your connection to FFXIVAPP was lost, please wait while we try to reconnect.